Posts Tagged ‘internet problem’

A vuelo razante

Hace una semana se nos dio dos días y medio para hacer el TP parcial de Procesamiento de Imágenes, y como era de esperar, a mí me quedó solamente un día y medio.
Si bien esta vez no fue tan extremo como el de Sistemas Inteligentes, también llegué con lo justo, entregándolo a las 2:20 de la madrugada (por Internet, por supuesto) y dejando el punto número 5 (eran 5 puntos en total) a la buena de Dios.
Se necesitaba un 60% para aprobar, y de haber tenido los ejercicios que había hecho completamente bien llegaba a 75%, pero sabía que por cosas que tenía algo flojas eso podía caer a alrededor de 65%. Y así fue, casi que me hizo sentir mejor que sacarme un 9, porque fue una estimación acertada de lo que podía hacer con los recursos (tiempo y conocimiento de la materia) que tenía. It’s a hit.

El otro motivo de orgullo (pre)profesional de ayer tuvo que ver con la épica lucha del hombre contra Telefónica. El jueves volvió otro técnico más, pero esta vez me cambió el módem y los filtros. Al principio todo era color de rosa, pero después empecé a perder la conectividad otra vez, y de nueeevo llamar al centro de soporte técnico.
Long story short: me dieron un router DSL, que se empezó a pelear con mi router, dando como resultado la ausencia de Internet cuando los conectaba.
Largas horas de trabajo no remunerado (obvio, ¿quién me lo va a remunerar?) me llevaron a aplicar las habilidades Javierísticas (¿Cómo? ¿No saben quién es Javier? ¡Deberían!) aprendidas en redes, configurando las subredes y el servicio DHCP como se debe, y trayendo nuevamente la paz a este hogar.

En dos semanas se define el cuatrimestre. El anteúltimo cuatrimestre de cursada. Good grief.

PD (si es que se pueden poner posdatas en un post antes de publicarlo): ¡El blog estrena tema nuevo!

Singin’ victory song!

¡Por fiiin! después de estar casi una dolorosa semana (en la que tenía que hacer y entregar trabajos) sin internet en Ubuntu, pude hacer que vuelva a andar.

La cosa empezó cuando, no extrañamente, se cayó el servicio de Speedy la tarde del último miércoles. La verdad es que no sé que fue lo que pasó, al principio directamente no se podía establecer la conexión, y después la cosa pasó a ser un problema de DNS. La cuestión es que después todo volvió a andar… en Windows.

Voy al problema concreto:

– Conexión en Windows funcionando normalmente.

– En Ubuntu (Hardy Heron 8.04) se conectaba, pero solamente podía acceder a Google (y sus amigos, como Gmail). No podía entrar a NINGUNA otra página, ni conectarme en ningún programa de mensajería, ni actualizar los repositorios, ni traer las letras de canciones con el Amarok.

– Todos los pings que hacía concluían satisfactoriamente.

¿Qué traté de hacer?: TODO. Modifiqué la configuración de red, tanto del módem como de PPP de todas las formas posibles, probé con todos los servidores DNS que se me cruzaron por el camino (ahora me doy cuenta que por el resultado de los pings, evidentemente ese no era el problema) y cambié unos cuantos archivos de configuración, sin resultados.

Y fue hace un rato cuando a través del caché de Google encontré esta página, que me dió la solución definitiva:

  • En un terminal, tipear sudo gedit /etc/ppp/options
  • Una vez abierto el archivo, buscar la línea que dice # mtu <n>
  • Descomentarla (borrar el #) y cambiar <n> por 1412
  • Guardar el archivo
  • Tipear en el terminal sudo poff dsl-provider, y después sudo pon dsl-provider (no sé si este paso es necesario, yo lo hice y funcionó)

Lo irónico de todo esto es que vi lo que era MTU (Maximum Transfer Unit) hace un par de clases en Redes I, pero lo que menos se me hubiese ocurrido es que ese era el problema.

Espero que esto le sirva a alguien más que haya estado en una situación tan desesperante como la mía :)